Apteryx- Outage

Incident Report for Fuse

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 08:26 CDT

Monitoring

Apteryx has implemented a fix, and we are monitoring the results.
Posted Mar 23, 2026 - 08:05 CDT

Investigating

XVWeb is currently experiencing connectivity issues. The vendor is working on this with the highest priority. Users may encounter a patient search screen when trying to view images. If seeing this, please refresh the page to see the images load on the left like normal (may have to refresh multiple times).

We sincerely apologize for the inconvenience this is causing your practice. Thank you for your continued partnership.
Posted Mar 23, 2026 - 07:51 CDT
This incident affected: Fuse (Imaging).